Delays in email notifications going out
Incident Report for Go1
Resolved
Notifications are now back to normal. Apologies for the disruption.
Posted May 19, 2020 - 23:34 AEST
Identified
We are currently experiencing delays in email notifications being sent out.
If you need any urgent help with adding users or resetting user passwords, please contact support@go1.com
Posted May 19, 2020 - 16:02 AEST
This incident affected: Go1.