Internet explorer not loading our webpage
Incident Report for GO1
Resolved
This issue has been resolved and we are happy to inform everyone that all portals are now accessible again using Internet Explorer.
Posted 11 days ago. Aug 14, 2019 - 19:27 UTC
Investigating
We received reports where our portal couldn't be loaded using Internet Explore, works in Chrome. Our team is currently looking into this issue.
Posted 11 days ago. Aug 14, 2019 - 10:50 UTC
This incident affected: GO1.