Enrolment Delay
Incident Report for GO1
Resolved
All delays in enrolments have been resolved. We will continue to monitor the situation and make sure it is working at 100%.
Posted about 1 month ago. Jul 23, 2019 - 01:56 UTC
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Jul 23, 2019 - 01:50 UTC
Investigating
We are currently experiencing delays with enrolments. Rest assured our team is investigating this issue and are working to resolve it.
Posted about 1 month ago. Jul 23, 2019 - 01:06 UTC
This incident affected: GO1.