Enrolment Tab
Incident Report for GO1
Resolved
This issue has been resolved
Posted 7 months ago. Feb 15, 2019 - 01:26 UTC
Investigating
Currently we are working on fixing the data display in the Enrolment tab
Posted 7 months ago. Feb 15, 2019 - 00:17 UTC
This incident affected: GO1.