Delay in emails going out
Incident Report for GO1
Resolved
We have cleared the backlog that was slowing down emails reaching inboxes. Emails should now be received nice and quick, as usual.
Posted 10 months ago. Jul 26, 2018 - 06:45 UTC
Monitoring
We have identified a backlog that is currently restricting the speed of emails reaching inboxes. We are in the process of clearing this backlog, but delays are expected in the interim.
Posted 10 months ago. Jul 26, 2018 - 06:29 UTC