Live Chat Function Currently Unavailable
Incident Report for GO1
Resolved
Thank you for waiting. Our Live Chat function is now available again. Our apologies for any inconvenience this may have caused.
Posted about 1 year ago. Feb 13, 2018 - 02:54 UTC
Investigating
We apologise that our Live Chat function is currently unavailable. We are working on getting this resolved as soon as possible. In the meantime please contact us either through support@go1.com or 1300 552 914. Thank you for your patience in this matter.
Posted about 1 year ago. Feb 13, 2018 - 00:28 UTC