Delay in Updating Status and Course Information
Incident Report for GO1
Postmortem

The GO1 platform users background processes to manage content and data. This technique is a widely used in the software industry to improve performance when dealing with lots of data. An internal change to our course catalog caused a job to be launched to updated most of our customers portals using premium or marketplace content. This caused a backlog of tasks that our system couldn't process within the normal timeframe of milliseconds to a few seconds.

We have put in place mitigations to avoid this type of tasks impacting normally user operations in the platform. We will be reviewing this part of our platform for further improvements we can make in this area.

Posted over 1 year ago. Feb 08, 2018 - 07:47 UTC

Resolved
The ability for GO1 systems to update course status has been restored across all portals. Thank you for your patience.
Posted over 1 year ago. Feb 08, 2018 - 05:57 UTC
Identified
Some GO1 portals are experiencing an intermittent delay in updating course and status information. We are aware, have diagnosed the issue and are implementing a solution. Apologies for any inconvenience caused, we will continue to update.
Posted over 1 year ago. Feb 08, 2018 - 03:19 UTC